Wiithon 1.0 liberado!!

POST ANTICUADO, última versión wiithon: 1.1 http://blogricardo.wordpress.com/2009/11/20/wiithon-1-1-publicado/

Actualizado: martes, 28 de julio de 2009

Creo que ya es el momento de publicar esta versión de wiithon con un GUI basado en GTK. Un desarrollo que empeze en abril, (trás publicar wiithon 0.98) sin tener apenas expriencia en GTK, gracias a Jose Luis Segura(LK2) y Google, he aprendido lo sufuciente en GTK para llegar al punto en el que estamos.

Sin dar más vueltas os expongo ls partes que va a tener esta presentación:

  1. Características
  2. Descargas
  3. Instalación
  4. Ejecución
  5. Actualización
  6. Traducir wiithon
  7. Agradecimientos.
  8. Team wiithon
  9. Screenshots

1. Características

Funcionalidades básicas
————————————————–
– Añadir fichero ISO mediante el típico selector de ficheros
– Extraer un juego a un directorio.
– Borrar un juego
– Ver espacio ocupado/total
– Ver número total de juegos.

Funcionalidades que hacen de wiithon ser “especial”
—————————————————
– GUI basado en GTK, exclusivo para GNU/Linux, funciona en cualquier distribución.
Gestionar múltiples particiones WBFS de forma sencilla- Diseñado con multilenguaje(i8n) para 16 lenguajes.
– Wiithon utiliza una base de datos(sqllite). Esto nos permite ver nuestra “juegoteca” con sus caratulas sin necesidad de tener conectada la partición WBFS.
– Wiithon esta preparado para ser asociado con ficheros ISO. Introducir una ISO sin preguntas. Simplemente hacer doble clic en nuestro gestor de archivos (nautilus, dolphin …).
– Eficiente buscador de juegos: busca en IDGAME y TITULO
Copia entre particiones WBFS. (Copia 1:1). Copiar 1 juego o todos, evitando cualquier reemplazo en el destino.
Refrescar particiones WBFS “en caliente”, sin tener que reabrir el programa.
– Opción de evitar ejecutar wiithon como root, y dar la opción de ejcutarlo en espacio de usuario.
– Añadir fichero ISO arrastrando (Drag & Drop)
– Añadir un directorio: buscará todas los ficheros ISO recursivamente
Renombrar nombre del juego (máximo 128 caracteres)
Renombrar idgame del juego (máximo 6 caracteres y ser letras y números)
– La tabla es ordenable por cualquiera de sus columnas.
Descarga caratula de portada y disco automáticamente (se guardan en ~/.wiithon/caratulas y ~/.wiithon/discos)
– Permite sincronizar nuestras caratulas y discos con la tarjeta SD, copiando solo caratulas y discos nuevos.
– Mantiene los comandos del wiithon 0.98 añadiendo el parametro “-c” o “–no-gui”
– Para operaciones sencillas (copiar caratulas, descargar caratulas) se utiliza paralelismo para acelerar el proceso (6 hilos).
– Para operaciones complejas (principalmente escribir/leer en WBFS) la operación es atómica (sin permitir paralelismo), esto es mejor así ya que una sola operación ocupa todo el ancho de banda de la entrada/salida. No obstante esta decisión de diseño sería facilmente modificable.

Problemas conocidos

- De los 16 idiomas que el Team propone, solo se ha traducido a 3: Español, Ingles y Brasileño.
– Como consecuencia de la librería libwbfs los porcentajes de progreso a veces distan un poco de la realidad.

Problemas desconocidos (léase bugs)

- El sitio oficial para reportar bugs es: https://bugs.launchpad.net/wiithon, aunque responderé tambien por aquí.

2. Descarga

Para la descarga del código fuente, he optado por utilizar el mismo repositorio que utilizamos para el desarrollo, aprovechando que como launchpad nos hostea el código he pensado que sería más comodo para todos, especialmente para actualizar.

Primero necesitamos instalar bazaar:
sudo apt-get install bzr

Ahora ya en la carpeta que queramos descargar el código fuente, ponemos:
bzr branch http://bazaar.launchpad.net/~wii.sceners.linux/wiithon/1.0 wiithon

Debido al último parámetro, se creará una carpeta wiithon, cambiamos:
cd wiithon

Ahora ya pasamos a la instalación

3. Instalación

Hay 2 opciones, en función de si vuestra distribución usa apt-get o no:

+  OPCION 1 (automática)

Desinstalará versiones anteriores, instalará antes todas las dependencias mediante apt-get y finalmente “wiithon”. Tambien corregira los permisos para poder utilizar wiithon sin root, el comando es el siguiente:

sudo make install_auto_and_fix

+  OPCION 2 (estándar)

Si no te gustan los automatismos o simplemente tu distribución no tiene apt-get, deberías hacerlo de esta forma:

1º    Desinstalar versiones anteriores de wiithon (si procede):
sudo make uninstall

2º  Dependencias, instalar estos paquetes:
intltool imagemagick rar menu python-sexy python-sqlalchemy python-gtk2 python-glade2 gnome-icon-theme

Además si tienes una plataforma de 64 bits, también debes instalar esta dependencia:
libc6-dev-i386

3º Instalar :
sudo make install

4º “Permisos”

Después de esto ya hemos terminado, tenemos wiithon en “Aplicaciones -> Oficina” o por consola con “sudo wiithon”,

si lo que queremos es evitar que nos pida contraseña, debemos continuar con el siguiente paso opcional, además este paso no es necesario si estamos actualizando, ya que con que se haya ejecutado 1 vez, nuestro usuario ya pertenece al grupo “disk”:

El comando es:
sudo make permissions_fix

Esto añadirá nuestro usuario al grupo “disk”, por tanto para que tenga efecto es posible que tengais que reiniciar GNOME / KDE.
Despúes de eso, wiithon será una aplicación ejecutada en el espacio de usuario. Con root no se juega!

4. Ejecución

El programa se encontrará en Aplicaciones -> Oficina (En KDE y GNOME).

¿Como ejecutarlo? :

1. Por Interfaz gráfico:
– Vaya a su menú de Aplicaciones, y encontrará Wiithon en la sección ‘Oficina’ (funciona en KDE y GNOME)

2. Por consola:
– sudo wiithon (o wiithon si puedes ejecutarlo sin necesitar los poderes de root)

5. Actualización

Posiblemente cuando me leais en los foros de que “he corregido tal bug” o he modificado tal cosa, os pediré que actualiceis, la ventaja de haber instalado por repositorio es que ahora es muy fácil actualizar. Por ello es importante conservar la carpeta de instalación generada en el paso 3.

Estando en la carpeta “wiithon” escribimos:
sudo bzr pull

Si os aparece “No revisions to pull.” es que no hay nada que actualizar.
En cambio si veis una barra de progreso, os ha actualizado.

Si os ha actualizado solo os queda repetir el paso 3 de “Instalación”.

6. Traducir Wiithon

En la carpeta “po” hay 16 lenguaje, escritos en formato de locale.

Aún hay muchos lenguajes sin traducir, traducirlos es muy fácil. Existen editores como “poedit” en GTK o  “lokalize” en Qt para facilitar la traducción.

Por ejemplo traduzco pt_BR.po.

Para probar la traducción del ejemplo debeis ejecutar el siguiente comando:

sudo make run LANGUAGE=pt_BR

Finalmente y no menos importante enviame el fichero xx_XX.po para que lo integre en el proyecto.

7. Agradecimientos

Agradezco el feedback recibido en la versión anterior, principalmente en el foro de EOL y en mi blog. Gracias a Sergio por traducir sin rechistar y a José por adoctrinarme en su perfeccionismo. Por supuesto agradecezco a todos los usuarios que vayan a utilizar el programa, y mucho más lo agradeceré si además me informan de los bugs.

8. Team wiithon

Si bien en la última versión yo era la única persona encargada del desarrollo, tras la publicación de la versión 0.98, LK2 me ofrecio su ayuda para la creación de este GUI. Por tanto el Team queda así:

Ricardo Marmolejo García <makiolo>
Jose Luis segura <LK2>
Sergio Padrino (solo ha podido hacer funciones de traductor y testeador)

9. Screenshots

Y por último, os dejo screenshots de wiithon en marcha:

GUI

About these ads

156 comentarios

  1. Para instalarlo en Ubuntu Jaunty 64 bits, se necesita instalar otro paquete más:

    sudo apt-get install libc6-dev-i386

    Gracias por tu programa.

    Saludos

  2. Elhodred, aunque te haya compilado en 64 bits, no es correcto del todo. Debido a como esta programado la librería libwbfs todos los managers de wbfs son compilados en 32 bits, y todos los intentos de compilar en 64, aunque se puede, despues obtienes “exception float” en tiempo de ejecución.
    Por tanto espera un momento que lo suba precompilado para 32 bits, que te funcionará perfecto desde 64.

    Un saludo. Ricardo

    • Hola Ricardo, la verdad no he terminado de entenderte. Yo baje las fuentes, hice un sudo make install_auto y me dio error con stubs-32.h. Entonces instalé el paquete libc6-dev-i386, volví a ejecutar sudo make install_auto y se instaló sin problemas. Probé a ejecutarlo y pasar una iso y todo funcionó sin problemas.

      Saludos.

      • En el momento que lo descargaste no estaba el compilado subido, para 32 bits no pasa nada, se compila y punto, pero en 64 yo por lo menos he tenido problemas en tiempo de ejcución.

        Fue en abril cuando intente compilar libwbfs en ubuntu 8.10 64 bits, y la verdad es que instale ese mismo paquete que mencionas, y no me funcionó. Lo quiero volver a probar ya que lo suyo es que cada uno se compile sus cosas. Alomejor la 9.04 lo compila bien, no lo se, encuento pueda lo pruebo, aunque si a tí te ha funcionado entonces funciona ;D

        No obstante te recomiendo que hagas el paso de actualizar por que he corregido un bug, poco importante pero bug.

  3. Ya esta solucionado, debes hacer el paso 4.

  4. Ey! A ver si para la siguiente release puedo hacer más que traducir 4 cosas, porque ahora entre mis escasos conocimientos en Python y en GTK y que he estado algo liadillo…

    Pero bueno, os ha quedado de puta madre! A ver si lo pruebo a fondo en KDE para comprobar que va bien el drag&drop y demás :P

    Un saludo!

  5. Solamente reportandome aqui para felicitarte por tu trabajo, si necesitas ayuda de traduccion o alguna otra cosa en que te pueda ayudar pues no más escribeme a xxxxxxxx@xxxxxxx.xx

    Editado por makiolo: ok, muchas gracias, creeme que lo tendre en cuenta. Te edito el comentario para evitarte spam de robots.

  6. Buena guia

  7. Gracias! pero si bien os he de confesar algo, el objetivo de este blog es en cierta forma ayudar al software libre, pero siento deciros que la primera motivación para hacer wiithon es totalmente egoista. Es lo que yo necesitaba, y en Linux no existía nada que me lo ofrecierá. Si además ayudo de alguna forma al software libre pues mucho mejor. Hablo por mi, desconozco las motivaciones de los demás ;P

    Por cierto, Añadida una característica que olvidé (además no es trivial, ni poca cosa):

    – Wiithon utiliza una base de datos(sqllite). Esto nos permite ver nuestra “juegoteca” con sus caratulas sin necesidad de tener conectada la partición WBFS.

    • Egoísta sería que lo desarrollases y no lo compartieses ;) . Que tu primera motivación sea: “uy, esto no existe y lo necesito, hala a hacerlo” no significa que seas egoísta, la mayoría de proyectos de SF empiezan así.

      Por cierto, actualizado tal y como me dijiste. Funciona a las mil maravillas.

      Saludos.

  8. [...] wiithon . WBFS GUI en Linux para WII . v0.98! Posted on Abril 7, 2009 by makiolo POST ANTICUADO, última versión wiithon: 1.0 http://blogricardo.wordpress.com/2009/06/21/wiithon-1-0-liberado/ [...]

  9. He probado la instalación en ubuntu 8.04 y xubuntu 8.04 32bits y en ambos casos la instalación va bien, pero la ejecución da el mismo error:

    sudo wiithon

    Traceback (most recent call last):
    File “/usr/local/bin/wiithon”, line 100, in
    App()
    File “/usr/local/bin/wiithon”, line 83, in App
    interfaz = WiithonGUI(core)
    File “/usr/local/share/wiithon/gui.py”, line 40, in __init__
    ‘wiithon.ui’))
    File “/usr/local/share/wiithon/builder_wrapper.py”, line 19, in __init__
    self.__builder.add_from_file( builder_file )
    gobject.GError: Unhandled tag: ‘requires’

    ¿ Alguna sugerencia ?

    • Buenas Jaime:

      wiithon necesita al menos gtk 2.14, me puedes decir que versión de GTK usas ?

      Un saludo

      • Hola makiolo,

        La verdad es que no esperaba una respuesta tan rápida !
        Por lo que he visto en el gestor de paquetes, tengo la 2.12 (libgtk2.0-0 indica versión 2.12.9-3ubuntu5). Voy a ver cómo actualizarla.

        Gracias,

        Jaime.

      • Hola Jaime:

        Existen versiones de GTK hasta 2.8+, hemos intentado ser cautos, para no obligar a la gente a ponerse versiones que ninguna distro lleva.

        La versión de GTK va muy relacionada con la versión de GNOME. Por lo que lo más sencillo es que te actualices a 8.10 al menos, yo ahora mismo estoy con 8.10, (no actualice por no tener tiempo ni disco duro libre xD).

        Un saludo

    • Hola Jaime de nuevo, al final he modificado wiithon para que funcione sobre versiones de gtk más antiguas. Si al final no has actualizado, ahora te debería funcionar.

      Un saludo.

      • Hola,

        Actualicé xubuntu a la 8.10 y me funciona sin problemas. Lo único que he notado es que no me salen los “tooltips” al situar el ratón sobre los iconos de la “barra de herramientas”, por lo que me tengo que imaginar lo que significan. Por lo demás, funciona estupendamente. Otra cuestión es que los juegos me funcionen bien en la Wii (usb loader 1.5, ios36 rev10). Hay muchos que se me quedan colgados sin venir a cuento (parece que cuanto más grande el juego, mayor la probabilidad). Entiendo que eso queda fuera del ámbito de este programa.

        Gracias,

        Jaime.

      • Es sencillo, no hay tooltips xD Esta hecho así para ahorrar trabajo para traducir, pero poco a poco se irán metiendo.

        Además de programar, soy usuario xD, y vamos el CIOS rev10 a nadie le funciona algunos juegos como el indiana jones y alguno más (normalmente de los nuevos). En cambio, con rev13a y fix002 activado en usbloader gx, funciona todo. Otra opción es, (NO LO HE PROBADO) según dicen, el CIOS de hermes 222, que parece ser que funciona todo, pero tendrás que configurar un loader que permita usar ese CIOS.+

        Por otro lado, tambien puede ser problemas con el disco duro (que se te hecha a dormir). O que te falta algún IOS, por ejemplo si usas el motion plus.

        Un saludo. Si encuentras cualquier fallo no dudes en ponerlo.

      • Hola,

        Quería comentar que he instalado la última versión en la otra máquina que tengo con ubuntu 8.04 (libgtk2.0-0 versión 2.12.9-3ubuntu5) y sigue dando el mismo error que te puse en el primer post. ¿Quizás en alguna de las modificaciones posteriores se ha perdido el cambio que habías hecho para que funcionara sobre versiones de gtk más antiguas?

        Gracias,

        Jaime.

      • He visto en el post de más abajo que habéis decidido no bajar la versión de gtk. Lo entiendo, al final terminaré actualizando el otro ubuntu también. Es sólo que la versión 8.04 es de soporte extendido, por eso no quería moverme a la 8.10.

        Saludos.

  10. Felicidades al team, la verdad es que está muy bien. Yo andaba con un script en consola un tanto cutre, se agradece algo más “visual”. Me falla copiando de partición a partición (mejor dicho de disco usb a disco usb): el disco duro al que copio el juego se apaga. Pero bueno, sabiendolo me da igual. Quizás sea cosa del disco, que es un poco quejica.
    El problema es que falla cuando lleva un rato copiando. ¿No tenías un parámetro ‘comprobar’? ¿Sigue estando?

    Saludos :)

    • Buenas flux

      Eh! un respeto al cli! xD pero amos, razón tienes. Por eso era prioritario hacer un GUI.

      El algoritmo de copia de WBFS a WBFS esta modificado a partir del wbfsGUI v14.1. Con permiso del autor y carteandonos por email pidiéndole consejo para que me diga cual era la versión más estable y como era la mejor forma de adaptarlo a Linux (su GUI es de windows). Por tanto si wbfsGUI tiene bug, wiithon tambien tiene el bug. Ahora mismo me va bien, todavía no me ha fallado ningúna transferencia, pero anteriormente con una función basada en wbfsGUIv12, no transfería ningún juego entre discos de distinto tamaño de sector, pero ahora esta solucionado.

      Prueba una cosa, wiithon (python) llama a un wiithon_wrapper, a veces este último da más información, prueba poner:

      wiithon_wrapper -p /dev/origenXY clonar IDGAME /dev/destinoXY

      Como ves hay 3 variables en el comando. Pruebalo y me comentas. Tambien pruebalo en distintos discos duros.

      Un saludo

      • flux@kamate:~$ wiithon_wrapper -p /dev/sdi2 clonar R4BPGT /dev/sdh1


        99.93;@;0;@;00;@;00
        99.96;@;0;@;00;@;00
        99.98;@;0;@;00;@;00
        FIN;@;0;@;00;@;10
        Se reinicia el disco y… tachan! clonado! :)

        Gracias! :)

      • Ah! y con eso de que yo andaba con un script un poco cutre me refería a uno
        mio, no al cli!!! xD

        Saludos :)

      • ah! weno xDD

        A mi tambien se me olvida una cosa:

        El parametro comprobar, de momento lo quite, ya que actualice la librería de wbfs y esa función la vi inútil, en cuanto pueda la vuelvo a meter (antes analizando si realmente la función sirve para algo, ya que bug de borrado, ahora mismo, nadie lo tiene.)

        Un saludo.

  11. A mi me da error al hacer lo de los permisos por lo que tengo que ejecutarlo haciendo el sudo previamente sino no reconoce la partición. Uso fedora 11. Me dice que el adduser no usa bien un parámetro o algo así.

    • Me podias hacer un favor, ahora mismo no tengo un fedora a mano.

      Averigua como se añade un determinado usuario a un determinado grupo en fedora, aver si así damos con un comando estandar, aunque según me dijo LK2, todos los GNU/Linux tiene “adduser”.

      Otra opción es el comando “gpasswd”, lo tienes ?

      Un saludo.

      • Pues al parecer el nombre del comando está bien pero falla en algún parámetro, te copio la salida:

        [twsh@Superlopez stable]$ sudo make permisos
        [sudo] password for twsh:
        adduser twsh disk
        Usage: useradd [options] LOGIN

        Options:
        -b, –base-dir BASE_DIR base directory for the new user account
        home directory
        -c, –comment COMMENT set the GECOS field for the new user account
        -d, –home-dir HOME_DIR home directory for the new user account
        -D, –defaults print or save modified default useradd
        configuration
        -e, –expiredate EXPIRE_DATE set account expiration date to EXPIRE_DATE
        -f, –inactive INACTIVE set password inactive after expiration
        to INACTIVE
        -g, –gid GROUP force use GROUP for the new user account
        -G, –groups GROUPS list of supplementary groups for the new
        user account
        -h, –help display this help message and exit
        -k, –skel SKEL_DIR specify an alternative skel directory
        -K, –key KEY=VALUE overrides /etc/login.defs defaults
        -l, do not add the user to the lastlog and
        faillog databases
        -m, –create-home create home directory for the new user
        account
        -M, do not create user’s home directory(overrides /etc/login.defs)
        -N, –no-user-group do not create a group with the same name as
        the user
        -o, –non-unique allow create user with duplicate
        (non-unique) UID
        -p, –password PASSWORD use encrypted password for the new user
        account
        -r, –system create a system account
        -s, –shell SHELL the login shell for the new user account
        -u, –uid UID force use the UID for the new user account
        -U, –user-group create a group with the same name as the user
        -Z, –selinux-user SEUSER use a specific SEUSER for the SELinux user mapping

        make: *** [permisos] Error 2
        [twsh@Superlopez stable]$

    • Escribe esto:

      1º sudo gpasswd -a $USER disk

      Literal, no hay ninguna variable en el comando.

      2º Borrate .wiithon de tu casa para evitar problemas de permisos

      3º Reinicia GNOME / KDE

      Pruebalo, y comentate algo aquí :D

      Si te funciona, cambiaré el comando por gpasswd que parece más universal.

      Un saludo

      • Ok, ha funcionado sin problemas, ya no tengo que hacer sudo para ejecutar wiithon y me vea el disco. Gracias.

  12. Hola,

    Is there an English install guide for this, I have tried using Google translate but it still slightly confusing.

    Sorry. Once installed I’d quite happily look at helping with any English translations for what looks a fantastic application.

  13. Hola!:

    ok, I will translate this guide within a week. (although wiithon already translated)

    • Hola,

      I have got it working now. Worked it out for myself in the end, thanks for your help. Brilliant piece of software and so much faster than the Windoze tools I have used.

  14. Thankyou, once I have this working I can dump Windows from my PC for good.

  15. Estupendo programa y no menos el tutorial para la descaga e instalación que me ha permitido, con mis limitados conocimientos, realizar todos los pasos con éxito.

    Una pregunta que a bien seguro no es del programa, o quizás no he encontrado la forma de hacerlo, tengo varios backups grabados en dvd y quería pasarlos al hd vía PC, ya que el lectos de la wii me falla ¿cómo podría realizarlo?

    Muchas gracias a todo el equipo y por adelantado a la respuesta.

    Saludos,

    • Esta en planes de futuro meterlo en GUI el dumpeo DVD -> WBFS.
      Digo en GUI porque en cli ya está, el comando es:
      wiithon -c instalar

      Esta parte esta muy verde, y hay que mejorarla, me funciona en la mayoría de juegos, pero en algunos no funciona, tengo que ver la forma de saltarme los errores de lectura. (el comando es el todopoderoso “dd”)

      Si no te funciona prueba esto, (que +o- lo que hace wiithon):
      dd if=/dev/cdrom of=juego.iso bs=1M

      Donde /dev/cdrom es tu lector de dvd (tambien puede ser /dev/cdrw, etc …). La salida sera un iso que posteriormente meterás en wiithon. Lo ideal sería copia “on the fly” como en wbfs a wbfs.

      Un saludo

      • Gracias makiolo,

        Lo he probado con un par de backups y me funcionan bien.

        Una pregunta ¿y tu cuando duermes? :)

      • mmmm wena pregunta, espero que no sea con mala intención xD

        La verdad es k cuando un proyecto me gusta, y veo que puedo aprender algo de todo esto, me cuesta mucho desconectar, cosa que muchos compañeros de mi uni no me comprenden.

        Pero vamos este verano me he propuesto desconectar un poco, más piscina, gimnasio, dar vueltas con el coche y dejar un poco el PC. El problema no sólo es el PC, tengo wii, xbox, ps3 … y soy una persona que se engancha muy facilmente a algo que le gusta, fui jugador de counter de la antigua escuela(con torneos y eso), y eso si que fue una época de no dormir … no te digo más xD

  16. Ricardo,

    Muchas gracias pelo excelente trabalho ! Programa maravilhoso, e funciona direitinho….
    Gostaria de traduzi-lo para o Português – Brasil, você chegou a implementar algo para facilitar a tradução ?

    Abraços….
    Alex

  17. Por fin — ya le tengo bastante mania win y esta era la respuesta que esperaba del mundo libre,,, (la resistensia unix/linux) … estupenda app …

    bueno una duda …cuando aplico lo de entrar como usuario no como root en el GUI
    no me detecta las particiones …. sin embargo como root si…esto solo ocurre cuando aplico el parch (sudo make permisos), si no lo aplico funciona bien..

    enorabuena….

    • Gracias por el comentario.

      Has probado a reiniciar GNOME / KDE ? Ese comando no es que sea un parche, sino que añade tu usuario al grupo “disk”. En linux si bien los permisos son instantántaneos, por eficiencia, el grupo al que pertenece cada usuario, solo es cargada al iniciar sesión.

      Un saludo.

  18. Hi, I changed from wiithon 0.98 to Wiithon 1.0 and when I connect my external hdd I keep getting this error:

    “There are no partitions WBFS – Connect a WBFS and press refresh.”

    The thing is that my hdd is already formatted in WBFS filesystem using wiithon 0.98 and has 50 or so games in it that play greatly on my Wii. :(

    Why isn’t the partition recognized in the new Wiithon 1.0?

    Also, how can I format my external hdd in WBFS filesystem using Wiithon 1.0?

    • Hi Malthador, I think that you write “wiithon” without “sudo”.
      If you dont want run wiithon in root space then you must write in wiithon install directory “sudo make permisos”. This add your user to group disk, for have permissions for read / write partitions in raw. Reboot GNOME / KDE

      Firstly test if detect your partitions with “sudo wiithon”.

      If you want format your partition FAT32(initial). This function is hidden in gui (for developers), but the function exists:

      wiithon_wrapper -p /dev/PARTITIONXX formatear

      • Yes, makiolo you were right.

        It was the root thingy that I forgot. :)

        Thanks for the quick response and thank you very very much for tha most awesome program up to date for the wii :D

        Keep in mind that you have to translate the installation guide in English so that more people can enjoy your marvellous program.

        Once more, Gracias :D

  19. :( lo instale a la primera pero cuando le doy para copiar el juego , eligo la iso y no hace nada. Alguien le ha ocurrido ?

  20. Cuando ejecuto wiithon me da el siguiente error:

    wiithon
    Traceback (most recent call last):
    File “/usr/local/bin/wiithon”, line 17, in
    from gui import WiithonGUI
    File “/usr/local/share/wiithon/gui.py”, line 12, in
    import glib
    ImportError: No module named glib

    Tengo Fedora 9 x64, y todas las dependencias estan instaladas.

  21. Mensaje para @snock y @JoseMGM:

    Gracias por el reporte, en ambos casos es un bug muy particular pero ahora esta solucionado. Debeis actualizar wiithon.

    Un saludo!

    • Despues de actualizar el y volver a reparar los permisos el error se repite.
      Si necesitas mas datos dimelo, pues no se que mandarte.
      un “# rpm -a”?

      • Se me olvido darte las gracias.

        Gracias.

      • Hola Jose:

        Pon “bzr revno”, te devuleve 23 no ? Si no alomejor es más facil borrar la carpeta y volverlo a bajar entero.

        Pasteame el error exacto, es imposible que sea igual, ya que en la linea 12 ya no esta glib.

        Un saludo

  22. sorry, but i can’t have this app in any language other than default.
    if i try with “sudo make install_auto_and_fix” it’s in spanish (i think).
    if i try with “sudo make run LANGUAGE=en” it run in english, but the app launched from the menù is still in spanish…
    so… what should i do?
    thanks in advance!

    • Thx for report.

      Language must autodetected by locale, only writing “wiithon”. If it fails always can create script with “LANGUAGE=en wiithon”

      Allthought. Can you print your “locale” output ?

      Bye

      • here it is:

        LANG=it_IT.UTF-8
        LC_CTYPE=”it_IT.UTF-8″
        LC_NUMERIC=”it_IT.UTF-8″
        LC_TIME=”it_IT.UTF-8″
        LC_COLLATE=”it_IT.UTF-8″
        LC_MONETARY=”it_IT.UTF-8″
        LC_MESSAGES=”it_IT.UTF-8″
        LC_PAPER=”it_IT.UTF-8″
        LC_NAME=”it_IT.UTF-8″
        LC_ADDRESS=”it_IT.UTF-8″
        LC_TELEPHONE=”it_IT.UTF-8″
        LC_MEASUREMENT=”it_IT.UTF-8″
        LC_IDENTIFICATION=”it_IT.UTF-8″
        LC_ALL=

      • Wiithon its translate in : es, en & pt_BR
        By default is : es, its my language native.
        IT its not translated, solution is do translation of “it.po”.

        Allthought you must update wiithon because I duplicate “en.po” as “it.po”.

        I hope that you happy :D sorry my english :D

  23. Gracias por vuestro excepcional esfuerzo, hasta ahora estuve trabajando con 0.98 pero decidí pasarme a 1.0.

    Tras instalar todo correctamente, al intentar ejecutar wiithon en una terminal me aparece lo siguiente:

    Traceback (most recent call last):
    File “/usr/local/bin/wiithon”, line 100, in
    App()
    File “/usr/local/bin/wiithon”, line 83, in App
    interfaz = WiithonGUI(core)
    File “/usr/local/share/wiithon/gui.py”, line 40, in __init__
    ‘wiithon.ui’))
    File “/usr/local/share/wiithon/builder_wrapper.py”, line 19, in __init__
    self.__builder.add_from_file( builder_file )
    gobject.GError: Etiqueta no soportada: «requires»

    Uso Debian Lenny.

    • Bueno tu reporte es un problema conocido, que ya se ha hablado arriba, tu distribución usa versiones de GTK menores a 2.14.

      Pense que no sería necesario, pero para solucionar el problema a tí y a tantos como tú he modificado sin problemas para que funcione en 2.12 o superior.

      Por tanto debes actualizar (cuando estoy escribiendo esto, la última revisión es la 22) y solucionado. confirmamelo plz.

      Un saludo

  24. Perdón, me di cuenta cuando ya envié el post (siento por estar duplicado).

    Efectivamente, Lenny viene con una versión bastante antigua de GTK+, la 2.12.
    He actualizado mediante bzr pull y he vuelto a instalar wiithon, pero al ejecutarlos me aparece:

    Traceback (most recent call last):
    File “/usr/local/bin/wiithon”, line 100, in
    App()
    File “/usr/local/bin/wiithon”, line 83, in App
    interfaz = WiithonGUI(core)
    File “/usr/local/share/wiithon/gui.py”, line 79, in __init__
    self.uimgr.insert_action_group(actiongroup)
    TypeError: GtkUIManager.insert_action_group() takes exactly 2 arguments (1 given)

    Probaré a actualizar GTK+ desde los paquetes unestable de Debian

    Gracias

    • mmmmmm ok …

      No obstante, me voy a poner esta tarde alguna distribución viejilla haber si consigo hacerlo funcionar en gtk 2.12.

      Gracias por el aviso.

    • Finalmente hemos decidido que wiithon tiene gtk 2.14+, bajar de versión nos limita mucho. Y algunas ideas que tenemos para el futuro quedan muy reducidas a menor es la versión de este.

      Un saludo!

  25. buenos dias, se que dicho comentario no va aquí, pero es que está cerrada su ubicación.
    Quería pedirte, si podias volver a subir el Laberinto TD, ya que ha sido borrado del servidor.
    Gracias y un saludo.

  26. Lo he probado en fedora 10 y funciona bien

    Muchas gracias Team

  27. He actualizado a la revisión 23.

    Esta actualización es imprescindible! debido a que la página proveedora de caratulas a cambiado de url y ha puesto ciertas trabas que he tenido que superar como imponer tener que venir de cierto sitio (referer). Ahora mismo funciona perfecto.

    Además he puesto una nueva característica: cuando arrastramos una imagen a la ventana de wiithon, esta foto se pone como caratula del actual juego seleccionado. Realiza las conversiones oportunas, redimensiona a 160×224 y lo pasa a PNG, requisito que estan pidiendo el 99% de los usb loaders.

    Un saludo.

  28. @makiolo

    thanks!
    the app works great!
    keep up!

  29. Me da error :(
    La primera vez lo inicie y se puso a descargar caratulas, pero siempre que elegía otro iso seguía saliendo la imagen de Mario Y SOnic en los JUegos Olímpicos, y no me dejaba añadir una iso ya que daba error, al cerrarlo e intentar volver a entrar aparece y desaparece

    EL error es este:
    dario@dario-desktop:~$ sudo wiithon
    raise exceptions.DBAPIError.instance(statement, parameters, e, connection_invalidated=is_disconnect)
    sqlalchemy.exceptions.ProgrammingError: (ProgrammingError) You must not use 8-bit bytestrings unless you use a text_factory that can interpret 8-bit bytestrings (like text_factory = str). It is highly recommended that you instead just switch your application to Unicode strings. u’UPDATE juegos SET title=?, device=? WHERE juegos.id = ?’ ['Mario & Sonic En los juegos ol\xc3\xadmpicos', '/dev/sdb2', 12]
    dario@dario-desktop:~$ file:///home/dario/Escritorio/wbffs-wrapper-0.2

    PUede ser por haber puesto una tilde en olímpicos ¿?

    Como puedo solucionarlo ¿?

    • Lo de los acentos no debería darte ningun problema.

      ¿Tienes actualizado wiithon a la revisión 23? escribe “bzr revno” para saber en que revisión estas.

      Si estas en la 23, es un bug, y me tienes que ayudar a detectarlo, primero dime que versiones tienes de:
      libgtk
      sqllite
      python-sqlalchemy

      Mientras tanto, puedes apoyarte en el CLI (wiithon pero con el parametro -c):

      Que salida te da el siguiente comando?

      wiithon -c ls

      Para probar cosas para hacer funcionar el GUI, puedes probar varias cosas, primero borraría la base de datos, borrando ~/.wiithon/bdd/*.db y probaría. Si no funciona tambien puedes renombrar o incluso borrar el juego por CLI.

      También para ayudarme a debugear, dime la salida de el siguiente comando:

      wiithon_wrapper -p /dev/TUDEVICE ls

      Me interesa mucho tu respuesta, ya que ahora mismo eres la única persona que le pasa, un saludo.

    • Estado buscando en google.
      Parece ser un bug de sqllite que puede ser facilmente evitado pasando todos los strings a unicode.
      Aun así sigo esperando tu respuesta.

      Gracias. Un saludo

    • Bueno, sin que me respondas, lo he solucionado a la espera de que me lo confirmes. Por tanto lo tengo en la versión de desarrollo, no la estable.

      Se instala igual pero cambia el paso 2:
      Para descargar el código:
      bzr branch http://bazaar.launchpad.net/~wii.sceners.linux/wiithon/trunk wiithon_trunk

      Entras : cd wiithon_trunk
      Y ya instalas: sudo make install_auto_and_fix

      Si ves una barra de estado que muestra información falsa, no te preocupes, es normal , por eso es la versión de desarrollo xD

      Un saludo.

  30. I briefly spoke here http://gbatemp.net/index.php?showtopic=165854 with makiolo (great program)

    I have problem compiling on anything but X86, is it due to “-m32″ – google tells me so :)

    I have a Debian box running testing (Squeeze I believe) and NO X WINDOWS SYSTEM . I ssh into into it.

    Don’t know if I’m missing libs (don’t think so) but would like to get it running

    • “-m32 works if gcc was built with multilib. If gcc -v says ‘–enable-multilib’, or doesn’t mention multilib, it should work. With tarballs, you can do CC=’gcc -m32′ ./configure , it works provided the libraries are there in 32 bit too. But building in a chroot is really failsafe, and then you can do a make install out of the chroot if there are no dependencies.”

      Source: http://ubuntuforums.org/archive/index.php/t-9957.html

  31. hola, yo la verdad es que no entiendo mucho de linux y tal… me estoy intentando poner un poco al tanto de las cosas y eso, jejeje.
    tengo el siguiente problema:
    Traceback (most recent call last):
    File “/usr/local/bin/wiithon”, line 100, in
    App()
    File “/usr/local/bin/wiithon”, line 83, in App
    interfaz = WiithonGUI(core)
    File “/usr/local/share/wiithon/gui.py”, line 41, in __init__
    ‘wiithon.ui’))
    File “/usr/local/share/wiithon/builder_wrapper.py”, line 19, in __init__
    self.__builder.add_from_file( builder_file )
    gobject.GError: Etiqueta no soportada: «requires»

    Sé que es un problema conocido, y que tengo que actualizar el gtk, pero no sé cómo hacerlo. a ver si pudiera tener un poco de ayuda al respecto^^
    he buscado en el synaptic, pero más de la 2.12 no encuentro… :S

    • Desgraciadamente, la versión de GTK va ligado con la versión de GNOME que a su vez suele ir ligado con la versión de la distribución …

      La única solución “fácil” es que actualices tu distribución.

      Un saludo.

  32. Felicidades por el programa, es fantástico, lo empecé a usar con la versión anterior. Y espero con impaciencia todas las mejoras que le estas haciendo. A mi se me ocurren un par de mejoras, una es que al poner el cursor sobre los iconos apareciese un texto explicativo sobre su función, la otra es que tenga la opción de quitarle la actualización, más que nada para no tener que usar otro programa para ello. Por lo demás es perfecto, mejor no lo podíais haber hecho. Gracias por el aporte al software libre.

    • Gracias por el comentario!
      La primera sugerencia (añadir tooltips), hay que hacerlo si o si ;D
      La otra sugerencia no la termino de entender.¿Eliminar bzr? Ahora mismo el desarrollo es muy activo, puede que cuando me plantee dejar de programar un largo tiempo ya lo distribuya en paquetes, pero ahora mismo no me compensa.

      Un saludo.

      • No me refería al bzr, el programa lo he actualizado una vez como indicaste y va perfecto. Me refería a quitarle la actualización al juego, he estado usando WiiBrickBlocker con Win$ virtualizado con VirtualBox, y ahora estoy usando WiiPatcher que lo puedo usar en Ubuntu. Esto por supuesto era una sugerencia, pues no se si sería posible.

  33. Hola.

    He instalado el programa y no inicia, da siempre el mismo error, pero es distinto al de los otros usuarios, así que te comento como lo he solucionado.

    El error era:

    sqlalchemy.exceptions.OperationalError: (OperationalError) unable to open database file None None

    Tras darle vueltas, he encontrado el problema: En lugar de hacer los pasos como indicas, con sudo, lo que hice fue entrar como root, compilar e instalar, por lo que en el archivo /usr/local/share/wiithon/HOME.conf puso la ruta a la carpeta de root, en lugar de la del usuario. Lo cambie y listo, pero eso me hace plantear dos cosas:

    – Probablemente el programa no funcione todo lo bien que debería en sistemas con más de un usuario, por problemas de permisos, o si alguien hace los pasos como yo.

    – Lo lógico (aunque no sé cómo de complicado es en Python) sería que al arrancar detectara el usuario y sobre eso sacase el valor para el HOME.

    En cualquier caso, espero no parecer que vengo con exigencias, nada más lejos de mi intención. Sólo darte las gracias por tu trabajo.

    • Hola umgah.

      Ok tomo nota sobre tus sugerencias.
      Me puedes responder un par de preguntas ?:
      – ¿Que distribución usas?
      – Instalaste por sudo, o por tal vez no tener sudo, como te hiciste root para instalar?

      Wiithon deduce el HOME en el momento de la instalación, el problema tal vez es que la instalación al ejecutarse como root, puede dar problemas detectando el verdadero usuario.

      Decidimos en su día por que “sudo echo $HOME” devuelve el home del usuario, no el del root, en todas las distribuciones que hemos probado. ¿No obstante me puedes decir la salida de ese comando ?

      En entornos multiusuario esta solución tienes razón en que da problemas, por ello voy a buscar una solución sencilla y efectiva para este problema.

      Gracias por el post.

      ———————————————-

      Ya que me pongo a escribir os comento que llevo programando desde el jueves a ratos para integrar WiiTDB.

      http://wiitdb.com/Game/HomePage

      El creador de WiiTDB me ha escrito un mail pidiendome integrar su base de datos con información de los juegos de wii + caratulas en wiithon. Yo le he contestado que por supuesto. De esta forma tendre TODA la información de un juego, synopsis(descripción de la contraportada), numero de jugadores, online, etc …. Ahora tengo que pensar el diseño de como meter todo eso sin romper con un diseño que trato que sea más limpio y simple.

      Un saludo.

      • Hola.

        La distribución es una Debian estable, con pequeños añadidos de testing (de hecho, el programa todavía no me funciona pese a haber actualizado la libgtk, aunque todavía tengo que investigar qué mas necesito actualizar desde testing para que funcione correctamente). He hecho la prueba que comentas y devuelve correctamente la ruta de mi home.

        Utilicé el usuario root porque tengo esa costumbre al hacer tareas administrativas, en lugar de emplear sudo, porque a fin de cuentas ya soy el administrador de mis máquinas, y así tengo los roles usuario/administrador totalmente separados. Probablemente por eso soy el primer caso, debo de ser raro :-)

        A lo que me refería con el problema de los permisos es a que si por ejemplo hay una máquina que usan varias personas, y una de ellas instala el programa, el programa va a coger como ruta la carpeta home de ese usuario, y cuando otra persona lo quiera usar no podrá (hasta donde yo sé, no es habitual en ninguna distribución el tener permisos de escritura en las carpetas de otros usuarios de forma predeterminada)

        Una solución posible sería coger el valor de la variable de entorno HOME del usuario cuando se inicia la ejecución del programa (supongo que la variable estará declarada también en otras distribuciones, parece bastante estándar) aunque no sé si es fácil acceder a variables de entorno desde el código Python. (Actualización: por probar, lo busqué en google y parece que sería tan sencillo como hacer myhome = `os.environ.get(“HOME”)` )

        Saludos.

      • jeje gracias por lo de la variable aunque realmente es:

        os.environ['HOME']

        Fuente: http://docs.python.org/library/os.html

        Al principio se hizo así para evitar la duplicacion de caratulas descargadas en distintos users,se hizo el invento del HOME.conf para ello queríamos que siempre se fuera a la misma carpeta la descarga de caratulas y resto de datos generados en ~/.wiithon en el momento de la instalación.

        Pero por cosas como lo ocurrido a tí, (no detecta correctamente el HOME) debemos cambiar el sistema en la prox versión y si duplica caratulas en root y en user pues no es tan grave como un problema de instalación.

        Un saludo. Ricardo.

      • Perdona, es que no sé Python y fue el primer resultado que apareció, y se trataba de un sistema que usa python embebido como lenguaje de scripting. Ni me paré a comprobar si era correcto.

        Bueno, si la motivación es no duplicar, una posible alternativa sería tener un directorio para ello en /usr/local/share/wiithon con permisos de escritura más laxos. Así, cada usuario podría tener su propia BD de juegos, pero las carátulas se mantendrían comunes.

        Por cierto, como detalle para casos raros como el mío, aparte de tener que actualizar el paquete libgtk2 a testing, también tuve que actualizar el paquete python-gtk2 (en perspectiva parece evidente, pero a mí se me coló en un primer momento).

        Saludos.

  34. Hoy me he comprado un disco duro de 500Gb para conectarlo a la Wii, pero Wiithon no me me detecta el disco. Hasta ahora estaba usando uno de 40Gb. Esto me hace pensar que es el sistema de archivos wbfs, que no admite esta capacidad.

    ¿Alguien lo sabe?. Gracias y saludos.

    • ¡Solucionado!
      He optado por la solución que siempre me ha funcionado en estos casos.
      Fdisk y Format del DOS de toda la vida, después le he dado formato WBFS en la Wii con ‘USB Loader’ y a meter los juegos.

      • Formatear con usb loader es una buena opción.
        Wiithon tambien puede formatear, aunque lo tengo bastante escondido por seguridad, al contrario que el wbfs manager de windows que pone “Formatear” en rojo, invitandote a la destrucción. Puede resultar dificil de creer, pero hay bastantes mensajes en foros de gente que ha formateado sus 500gb por que confio en un botón rojo.

        Un saludo!

      • A mi no me resulta dificil de creer, teniendo en cuenta que hay muchísima gente que no usa un Linux, porque les da miedo formatear.

        A mi sin embargo me gustaría saber como se puede formatear con Wiithon.

        Por cierto ayer cuando metí como unos 30 juegos, renombre algunos y en uno le puse un acento. Wiithon dejó de funcionar correctamente, lo cerre y no se habría, probé entonces en consola, Wiithon si se ejecutaba pero no se habría la ventana, en la consola salia un montón de mensajes de errores, en una linea ponía algo de 8bits, bueno se me ocurrió probar en la Wii. Efecivamente en donde puse el acento, salian unos signos raros, borré el juego y Whiithon volvió a funcionar bien.
        Tengo la última versión (v24). Espero te sirva.

      • P.D.

        El día 13th Julio te conteste, a que tipo de actualización me refería. Solo quería saber como lo ves, si es posible. Gracias por contestar.

  35. Enhorabuena por este gran trabajo!Aunque tengo una pequeña duda, es compatible con memorias usb con más de una partición?

    Tengo una memoria de 8 gigas con dos particiones, una en fat32 y la otra en wbfs pero no consigo acceder a esta partición, no me aparece la memoria usb no se si puede ser por el lector de tarjetas integrado en el portátil (Compal IFL90). De momento voy a probar una alternativa en el ventanas a ver si veo los juegos que instalé desde la consola en la partición de la SD

    • Hola Escu:

      Wiithon es compatible con multiples particiones WBFS, tu sólo tienes 1 partición WBFS,por tanto es correcto, cualquier otro tipo de particiones son ignoradas, ya que es un manager wbfs, lo único que podrías hacer es convertir la partición fat32 en wbfs.

  36. [...] des de GNU/Linux, hi ha un programa que es diu Wiithon que simplifica molt aquesta tasca. La seva instal·lació no es fa de la forma habitual (Synaptic o apt-get), tot i que els seus programadors l’han fet [...]

  37. Hola,

    Solo felicitarte por este estupendo programa. Llevo utilizandolo un par de días y va perfecto (ubuntu network remix). Sencillo, útil, eficaz.

    Gracias por el aporte.

  38. Ciao,

    great program! have you in mind support for .rar and .ciso (in/out) ?

    thanks

  39. Hola,

    Lo primero darte las gracias por tu programa. Y ahora te comento que descubrí wiithon hace un par de días y me viene funcionando de maravilla. Tengo ubuntu 9.04 y lo utilizo con un samsung 160 Gb externo. Todo de perlas, aunque a veces al añadir una iso no hace nada, busco en la carpeta y elijo la iso, pero no parece reaccionar. Sin embargo con la opción de añadir directorio sí la copia. Te lo comento por si te sirve de algo.

    Saludos y gracias otra vez.

  40. enora buena x este pedazo de tuto xd.. tengo la wii haze caxo con el dico duro y los juegos tenia windows xp y me iva de p.m..y se me rompio el pc y me compre un pc con linux hace 1 semana y me molo caxo mas y esto del linux pero al instalar wiithon me da este fallo….
    Traceback (most recent call last):
    File “/usr/local/bin/wiithon”, line 100, in
    App()
    File “/usr/local/bin/wiithon”, line 83, in App
    interfaz = WiithonGUI(core)
    File “/usr/local/share/wiithon/gui.py”, line 41, in __init__
    ‘wiithon.ui’))
    File “/usr/local/share/wiithon/builder_wrapper.py”, line 19, in __init__
    self.__builder.add_from_file( builder_file )
    gobject.GError: Etiqueta no soportada: «requires»

    y nu tengo cojones a arancarlo
    necesito ayuda please y muixas gracias x todo

  41. nas llevo pokisimo en linux y te agradezco lo bien detallao k esta xD.
    Con esta version se pueden borrar los juegos “corruptos?”; me refiero por ejemplo a un juego k ocupa 3.5 Gb y tu solo tienes 3 gb libres y no te das cuenta y lo copias, al final dssaparecen los 3gb y el juego no aparece.

  42. @fleky: ese error es debido a que wiithon necesito gtk 2.14, prueba actualizar tu distribución de linux, que seguro que lleva gtk 2.14 o 2.16 mínimo.

    @ShaDoW: eso sería un bug de libwbfs(uso la versión que usa el usb loader gx) y desde luego yo usando wiithon nunca me ha pasado. Si metes un juego y luego no cabe, da un error en el puto que llena, pero digamos que es el final cuando se reserva ese espacio, por tanto como en caso de full disk no llega al final esos bytes copiados quedan dereferenciados / sueltos / basura y se consideran espacio libre.

    Un saludo!

  43. gracias por la respuesta pero el usb loader gx no encuentra ni el juego ni los 3Gb k tenia,
    wiithon reconocera los 3Gb basura como espacio libre?
    el error me lo dio al 75% +-

  44. Hi,

    Thanks for this great program. I made a translation in french. I don’t understand spanish so I tried to guess and mainly used english translation. As I didn’t explore all options of wiithon some sentences may sound strange but french people should understand.

    I’ve uploaded the “fr.po” file here : http://ul.to/sh087p
    and here too : http://dl.free.fr/rWT6rNy9J

    There seemed to be some duplicate sentences too.
    I can improve this translation later if you update the main file : just send me an email if you don’t find a spanish-french translator ;)

    *************************
    Pour les français : j’ai traduit wiithon (fichier fr.po à mettre dans le dossier source) mais comme j’ai pas testé toutes les options quelques phrases sont peut-être étranges, mais ça devrait être compréhensible.

    C’est là :

    http://ul.to/sh087p

    ou

    http://dl.free.fr/rWT6rNy9J

  45. No puedo subir ISOs?

    Traceback (most recent call last):
    File “/usr/local/share/wiithon/gui.py”, line 966, in on_tb_toolbar_clicked
    self.juegoNuevo = session.query(Juego).filter(‘idgame==”%s” and device==”%s”‘ % (idgame , self.DEVICEParticionSeleccionada)).first()
    File “/var/lib/python-support/python2.6/sqlalchemy/orm/query.py”, line 909, in first
    ret = list(self[0:1])
    File “/var/lib/python-support/python2.6/sqlalchemy/orm/query.py”, line 938, in __iter__
    return self._execute_and_instances(context)
    File “/var/lib/python-support/python2.6/sqlalchemy/orm/query.py”, line 941, in _execute_and_instances
    result = self.session.execute(querycontext.statement, params=self._params, mapper=self.mapper, instance=self._refresh_instance)
    File “/var/lib/python-support/python2.6/sqlalchemy/orm/session.py”, line 628, in execute
    return self.__connection(engine, close_with_result=True).execute(clause, params or {})
    File “/var/lib/python-support/python2.6/sqlalchemy/engine/base.py”, line 844, in execute
    return Connection.executors[c](self, object, multiparams, params)
    File “/var/lib/python-support/python2.6/sqlalchemy/engine/base.py”, line 895, in execute_clauseelement
    return self._execute_compiled(elem.compile(dialect=self.dialect, column_keys=keys, inline=len(params) > 1), distilled_params=params)
    File “/var/lib/python-support/python2.6/sqlalchemy/engine/base.py”, line 907, in _execute_compiled
    self.__execute_raw(context)
    File “/var/lib/python-support/python2.6/sqlalchemy/engine/base.py”, line 916, in __execute_raw
    self._cursor_execute(context.cursor, context.statement, context.parameters[0], context=context)
    File “/var/lib/python-support/python2.6/sqlalchemy/engine/base.py”, line 960, in _cursor_execute
    self._handle_dbapi_exception(e, statement, parameters, cursor)
    File “/var/lib/python-support/python2.6/sqlalchemy/engine/base.py”, line 942, in _handle_dbapi_exception
    raise exceptions.DBAPIError.instance(statement, parameters, e, connection_invalidated=is_disconnect)
    sqlalchemy.exceptions.OperationalError: (OperationalError) unrecognized token: “”” u’SELECT juegos.id AS juegos_id, juegos.idgame AS juegos_idgame, juegos.title AS juegos_title, juegos.size AS juegos_size, juegos.device AS juegos_device \nFROM juegos \nWHERE idgame==”\x00\x00\x00\x00\x00\x00″ and device==”/dev/sdb1″ ORDER BY juegos.oid \n LIMIT 1 OFFSET 0′ []

  46. Makiolo, estoy intentando instalar el wiithon en mi PC con Mandriva 2009.1 KDE4, he bajado las dependencias (en Mandriva está unrar, intltool, python-sexy, pythonsqlalchemy, pyggtk2.0-devel y pyggtk2.0-libglade) y en el make install me dice:

    [root@localhost wiithon]# make install
    make -C wiithon_wrapper
    make[1]: se ingresa al directorio `/home/momi/wiithon/wiithon_wrapper’
    gcc -Wall -m32 -W -g -ggdb -Ilibwbfs -I. -m32 -static wiithon_wrapper.o libwbfs.o libwbfs_linux.o wiidisc.o rijndael.o -L. -o wiithon_wrapper
    /usr/bin/ld: cannot find -lc
    collect2: ld devolvió el estado de salida 1
    make[1]: *** [wiithon_wrapper] Error 1
    make[1]: se sale del directorio `/home/momi/wiithon/wiithon_wrapper’
    make: *** [wiithon_wrapper/wiithon_wrapper] Error 2
    [root@localhost wiithon]# make install
    make -C wiithon_wrapper
    make[1]: se ingresa al directorio `/home/momi/wiithon/wiithon_wrapper’
    gcc -Wall -m32 -W -g -ggdb -Ilibwbfs -I. -m32 -static wiithon_wrapper.o libwbfs.o libwbfs_linux.o wiidisc.o rijndael.o -L. -o wiithon_wrapper
    /usr/bin/ld: cannot find -lc
    collect2: ld devolvió el estado de salida 1
    make[1]: *** [wiithon_wrapper] Error 1
    make[1]: se sale del directorio `/home/momi/wiithon/wiithon_wrapper’
    make: *** [wiithon_wrapper/wiithon_wrapper] Error 2

    Podrá ser alguna librería, no se si conocerás a alguien que ya lo haya probado en Mandriva. Te agradezco la ayuda de antemano.

    • otra cosa ./wiithon.py carga el programa y ubica la partición /dev/sdb2 pero no muestra los juegos.

    • -Instala paquetes con referencia a “glibc” y me comentas.

      -No ejecutes ./wiithon.py, no funcionarán bien algunas rutas, debes instalarlo.

      Un saludo

      • Gracias Makiolo, me ayudo tu respuesta. Creo que me faltaba la librería glibc-static-devel de Mandriva, luego de instalarla corrió de lo mejor.

        Excelente programa.

  47. Buenas makiolo, tengo un problemilla.

    Traceback (most recent call last):
    File “/usr/local/bin/wiithon”, line 100, in
    App()
    File “/usr/local/bin/wiithon”, line 83, in App
    interfaz = WiithonGUI(core)
    File “/usr/local/share/wiithon/gui.py”, line 41, in __init__
    ‘wiithon.ui’))
    File “/usr/local/share/wiithon/builder_wrapper.py”, line 19, in __init__
    self.__builder.add_from_file( builder_file )
    glib.GError: ID «label1» de objeto duplicado en la línea 487 (anteriormente en la línea 300)

    Versión de python 2.5.4

    Un saludo.

    • Ah y libgtk 2.16

    • Bueno si a nadie más le va mal por mi parte está solucionado, he renombrado algunas ID que había duplicadas en wiithon.ui y listo.

      Un saludo.

      • Buenas noches Pedja, me podrias indicar como solucionastes tu problema ya que a mi me da el mismo error pero no se que hacer, Gracias.

        Excelente trabajo Makiolo

      • Actualiza a la revisión 25, creo que con eso se debería haber solucionado.

    • Gracias por el aviso. Ya he visto ese error antes. Curiosamente algunas versiones permiten elementos gtk con el mismo nombre en el mismo UI pero en distintas ventanas. En cambia otras versiones, posiblemente de glade, neesitan desambigüación total.

      No repetiré ningún nombre para la siguiente versión. Que versión de glade usas ?

      Un saludo!

      • Uso la 2.6.4

        Por cierto ¿te puedo hacer una petición para la 1.1?
        Me gustaría que hubiera la posibilidad de varios usuarios, es decir que en lugar de tener definido el home en HOME.conf usara automáticamente el del usuario que está usando la aplicación.

        Un saludo.

      • Ya esta hecho eso, ahora los caratulas y discos son descargadas en espacio de sistema, y todos los usuarios comparten las caratulas.
        Cada usuario tiene su base de datos, eso implica que cada uno tiene sus juegos y sus preferencias.

  48. perdonar si tardo en contestar, estoy con examenes de septiembre.
    Espero para octubre sacar wiithon 1.1 arreglando bugs y nuevas cosillas.

    Un saludo.

  49. Felicidades Makiolo por el excelente trabajo realizado.

    Soy usuario de linux Fedora 11 y estoy tratando de compilar el wiithon_wrapper pero me sale el siguiente error ya no se que hacer alguien lo ha podido instalar en esta distro?

    make install

    make -C wiithon_wrapper
    make[1]: Entering directory `/home/jose/wiithon/wiithon_wrapper’

    gcc -Wall -m32 -W -g -ggdb -Ilibwbfs -I. -DLARGE_FILES -D_FILE_OFFSET_BITS=64 -c wiithon_wrapper.c -o wiithon_wrapper.o

    gcc -Wall -m32 -W -g -ggdb -Ilibwbfs -I. -DLARGE_FILES -D_FILE_OFFSET_BITS=64 -c libwbfs/libwbfs.c -o libwbfs.o

    gcc -Wall -m32 -W -g -ggdb -Ilibwbfs -I. -DLARGE_FILES -D_FILE_OFFSET_BITS=64 -c libwbfs/libwbfs_linux.c -o libwbfs_linux.o

    gcc -Wall -m32 -W -g -ggdb -Ilibwbfs -I. -DLARGE_FILES -D_FILE_OFFSET_BITS=64 -c libwbfs/wiidisc.c -o wiidisc.o

    libwbfs/wiidisc.c: In function ‘wd_fix_partition_table’:
    libwbfs/wiidisc.c:312: warning: unused parameter ‘d’

    gcc -Wall -m32 -W -g -ggdb -Ilibwbfs -I. -DLARGE_FILES -D_FILE_OFFSET_BITS=64 -c libwbfs/rijndael.c -o rijndael.o

    gcc -Wall -m32 -W -g -ggdb -Ilibwbfs -I. -m32 -static wiithon_wrapper.o libwbfs.o libwbfs_linux.o wiidisc.o rijndael.o -L. -o wiithon_wrapper

    /usr/bin/ld: cannot find -lc
    collect2: ld returned 1 exit status
    make[1]: *** [wiithon_wrapper] Error 1
    make[1]: Leaving directory `/home/jose/wiithon/wiithon_wrapper’
    make: *** [wiithon_wrapper/wiithon_wrapper] Error 2
    [root@optimus wiithon]#

    La interfaz del wiithon funciona sin problemas, les agradecer la ayuda prestada.

    Saludos y hasta luego

  50. Tengo el disco duro wbfs tiene 47 juegos pero no lo detecta wiithon y seria un trabajo gordisimo formatearlo y tener q volver a ponerlos todos no hay alguna solucion sin formatear?

    Un Saludo

  51. ¿Se puede usar Wiithon 1.0 sin necesidad de GUI? Lo digo para no tener que actualizar mi Debian Estable y al mismo tiempo tener las ventajas y mejoras de 1.0 frente a 0.98.

    Gracias.

  52. Muchísimas gracias por el curro. Me ha costado un poquillo, principalmente porque no encontraba el wbfs, pero una vez creada la partición funciona a la perfección. Estaria bien poder formatear las particiones directamente desde Wiithon sin tener que recurrir al binario wtfs, aunque no sé hasta que punto sería posible. Y ya una pijadilla sería poder ver la velocidad de escritura en la barra de progreso.

  53. Hi,
    i need help, with debian squeeze … :

    n# wiithon
    /usr/local/share/wiithon/juego.py:52: SADeprecationWarning: The ‘transactional’ argument to sessionmaker() is deprecated; use autocommit=True|False instead.
    autoflush=True, transactional = True)
    /usr/local/share/wiithon/preferencias.py:53: SADeprecationWarning: The ‘transactional’ argument to sessionmaker() is deprecated; use autocommit=True|False instead.
    Session = sessionmaker(bind=motor , autoflush=True, transactional = True)
    Traceback (most recent call last):
    File “/usr/local/bin/wiithon”, line 100, in
    App()
    File “/usr/local/bin/wiithon”, line 83, in App
    interfaz = WiithonGUI(core)
    File “/usr/local/share/wiithon/gui.py”, line 41, in __init__
    ‘wiithon.ui’))
    File “/usr/local/share/wiithon/builder_wrapper.py”, line 19, in __init__
    self.__builder.add_from_file( builder_file )
    glib.GError: Identifiant d’objet « label1 » dupliqué à la ligne 487 (précédemment à la ligne 300)

  54. Thanks You …
    rev25 works fine on Debian Squeeze & Ubuntu Karmic Alpha6

    ps: now i can remove ubuntu :) :) :)

  55. Solo queria felicitarte. Un gran programa y que es con el que estreno usar la terminal. Me ha parecido tan alucinante ver esa ristra de ordenes ejecutándose y que luego aparezca un nuevo programa que no puedo mas que aplaudir. Tan solo criticar que al copiar un nuevo juego no se actualiza la lista hasta que no reinicias.
    Un aplauso

  56. Tio…. solo te puedo felicitar. Va de p*** madre !!!

  57. No consigo hacer que me funcione en Ubuntu 9.04.
    Compilo bien pero me dá el siguiente error de ejecución:
    /var/lib/python-support/python2.6/gtk-2.0/gtk/__init__.py:72: GtkWarning: could not open display
    warnings.warn(str(e), _gtk.Warning)
    /usr/local/share/wiithon/util.py:201: GtkWarning: gtk_clipboard_get_for_display: assertion `display != NULL’ failed
    __clipboard = gtk.Clipboard() # This is a singleton
    Traceback (most recent call last):
    File “/usr/local/bin/wiithon”, line 14, in
    import config
    File “/usr/local/share/wiithon/config.py”, line 12, in
    import util
    File “/usr/local/share/wiithon/util.py”, line 199, in
    class Entry(sexy.IconEntry):
    File “/usr/local/share/wiithon/util.py”, line 201, in Entry
    __clipboard = gtk.Clipboard() # This is a singleton
    RuntimeError: could not create GtkClipboard object
    root@torrelinux:~/.wiithon/bdd# wiithon
    /var/lib/python-support/python2.6/gtk-2.0/gtk/__init__.py:72: GtkWarning: could not open display
    warnings.warn(str(e), _gtk.Warning)
    /usr/local/share/wiithon/util.py:201: GtkWarning: gtk_clipboard_get_for_display: assertion `display != NULL’ failed
    __clipboard = gtk.Clipboard() # This is a singleton
    Traceback (most recent call last):
    File “/usr/local/bin/wiithon”, line 14, in
    import config
    File “/usr/local/share/wiithon/config.py”, line 12, in
    import util
    File “/usr/local/share/wiithon/util.py”, line 199, in
    class Entry(sexy.IconEntry):
    File “/usr/local/share/wiithon/util.py”, line 201, in Entry
    __clipboard = gtk.Clipboard() # This is a singleton
    RuntimeError: could not create GtkClipboard object

    Gracias por adelantado.

    • mmm, este problema nunca se ha dado antes, ¿ que versión de gtk usas ?

      • pues la verdad no lo se ni sé como mirarlo, tengo el Ubunto 9.04 recien instalado.

      • busca el paquete libgtk2.0-0 y dime que versión.

        Tambien asegurate que cumples las dependencias:
        intltool imagemagick rar menu python-sexy python-sqlalchemy python-gtk2 python-glade2 gnome-icon-theme

        De hecho el paquete que creo que te falta es:
        python-sexy

        Que es usado para crear la escoba que limpia el textbox, lo que haré en siguientes versiones, es hacerlo opcional.

        Un saludo.

  58. De libgtk2 tengo la versión 2.16.1-0ubuntu2.
    Respecto a los paquetes de las dependencias, los tengo todos pero los he marcado para reinstalar por si acaso. Y las versiones:
    intltool 0.40.6-1
    imagemagick 7:6.4.5.4.dfsg1.1ubuntu3.1
    rar 1:3.8.0-2
    menu 2.1.41ubuntu1
    python-sexy 0.1.9-1ubuntu2
    python-sqlalchemy 0.4.8-1
    python-gtk2 2.14.1-1ubuntu1
    python-glade2 2.14.1-1ubuntu1
    gnome-icon-theme 2.26.0-0ubuntu1

    Gracias por tu interes.

  59. Buenas noticias, tras reinstalar todas las librerías de las dependencias ahora mismo me funciona.

    Gracias por todo…..

  60. Buenas, uso mandriva 2009.1, no soy capaz de hacer que funcione, e echo todo lo que deciis, instalar las librerías libgtk y glibc.
    no e conseguido compilarlo ni instalarlo ya que los comandos make e install no me los reconoce. lo máximo que e llegado a sido poner ./wiithon.py y me sale el programa pero no me sale los juegos que tengo en el pen drive…
    a ver si me podeis ayudar.

  61. despues de provar varias cosas ya e conseguido hacerlo funcionar, lo voy a explicar por si alguien tiene el mismo problema:
    1. instalar el comando make “urpmi make”
    2. luego poner “make install” en la carpeta de wiithon y solucionado…
    como se nota que soy nuevo en esto de linux xD

    • Gracias por el comentarlo.

      Me parece un gran error por parte de mandriva no incluir ‘make’ ya instalado. Pero weno, como dices, nada que no se solucione con un “urpmi make”, despues son las mismas instrucciones explicadas en el post.

      Un saludo.

  62. Hola, he tratado de compilarlo en Mac OS X usando las dependencias de MacPorts, pero sin exito. Obtengo este error:

    Undefined symbols:
    “_wbfs_try_open_partition”, referenced from:
    _wiithon_wrapper_clonar in wiithon_wrapper.o
    _main in wiithon_wrapper.o
    “_wbfs_try_open”, referenced from:
    _main in wiithon_wrapper.o
    ld: symbol(s) not found
    collect2: ld returned 1 exit status
    make[1]: *** [wiithon_wrapper] Error 1
    make: *** [wiithon_wrapper/wiithon_wrapper] Error 2

    Alguien lo ha logrado?

    • No he probado nunca en Mac. Prueba a compilar el libwbfs y el wiithon_wrapper de la versión trunk (cambia stable por trunk en el comando de descarga de código).

      No obstante comprueba que puedes comppilar (gcc, ld …)

  63. Si alguno quiere betatestear la versión 1.1 mirar este post: http://www.elotrolado.net/hilo_act-wiithon-1-0-tags-wbfs-gui-gtk-f-cil-linux_1216486_s160#p1717727348

    Y una imagen de como va la 1.1:

  64. me darias permiso para postear esto haciendo un descarado copy-paste en wiisos???

    obviamente dandote los respectivos THANKS

    staff wiisos.com

    espero tu respuesta

    • hola jambus:

      claro, pero haz referencia a este blog como fuente actualizada, y explicando que
      pronte saldrá una versión nueva que esta muy avanzada pero necesita más pruebas para considerarse estable.

      Un saludo.

      • ok ok
        genial

        si quieres me pasas el link de la version 1.3 q es la beta, no?

        en la pagina hay varios q les gustaria ser beta-testers… incluyendome

        ;¬)

        saludos

  65. menu no existe en Gentoo :P
    python-sexy es sexy-python
    python-sqlalchemy es sqlalchemy
    python-gtk2 es pytgk
    python-glade2 no existe en Gentoo

    La aplicación funciona pero solo se ve un icono, el de borrar, el resto no los encuentra :)

    • jeje :P

      “python-sexy” es opcional, solo sirve para meter una escoba dentro de un gtk.Entry xD

      Menu es otro opcional.

      Fuertes dependencias son python, gtk, sqlalchemy, glade.

      Sobres los cambios de nombre, solo comentar que complica la existencia a los desarrolladores, pero que se le va hacer :D

      Sobre los iconos, eso me paso en un KDE y lo resuelve la dependencia “gnome-icon-theme”(esta puerto en el tutorial). Que son los iconos de gnome.

      Siendo gentoo se llamará theme-icon-g o alguna permutación aleatoria xD. Es broma :D

      No obstante la semana que viene publico la nueva versión. Estoy a la espera de la traducción a alemán y francés. Si quieres ayudarme para integrarlo mejor en Gentoo añádeme al GTalk.

      Un saludo. Ricardo

  66. La nueva versión esta muy madura, la publicaré la semana que viene ya fijo ;D

  67. Sólo quería agradecer el tremendo trabajo y esta estupenda aplicación !

    Gracias :)

  68. Es posible que el repositorio esté caido? hace un par de dias que intento descargar wiithon y no lo consigo, da error de que no existe la “branch” stable…
    Gracias y felicidades por la aplicación, tiene muy buena pinta!

  69. [...] la nostra sessió d’usuari. A partir d’aquí, cal instal·lar el Wiithon. La seva instal·lació no es fa de la forma habitual (Synaptic o apt-get), tot i que els seus programadors l’han fet [...]

  70. Muchas gracias

  71. Pretty section of content. I simply stumbled upon your website and in accession capital to assert that I
    get in fact loved account your weblog posts. Any way I will
    be subscribing for your feeds or even I fulfillment you get
    right of entry to consistently rapidly.

Deja un comentario

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

Seguir

Recibe cada nueva publicación en tu buzón de correo electrónico.

A %d blogueros les gusta esto: