Instalar últimos drivers de ATI/NVIDIA fácilmente con Envy

Envy, es una de las soluciones que tenemos para instalar fácilmente nuestros drivers gráficos. Gracias a un estupendo trabajo de Alberto Milone podemos disfrutar de la instalación de nuestros drivers de manera gráfica, ya que el proyecto surge como un script, pero posteriormente adquirio una GUI sencilla, pero suficiente para lograr su objetivo.
Envy es una aplicación escrita en PyGTK la cual tienen la función de detectar, descargar e instalar el driver tu tarjeta de video.
Para instalarlo, simplemente vete a su página y bajate el último deb para tu versión de ubuntu, despues lo abrimos Aplicaciones \ Herramientas del sistema \ Envy y le damos a Instalar el driver de NVIDIA o ATI. Envy detecta tu tarjeta de gráfica y descarga los drivers propietarios directamente de la misma web de ATI o Nvidia según sea el caso.instala las dependencias para compilar el módulo, reescribe el archivo xorg.conf, reinicia las X y voilá ya tienes instalados tus drivers.
Ahora mismo las versiónes de Envy estan así:
Última versión de driver que esta instalando el envy:
  • NVIDIA: 169.09 , 96.43.01 y 71.86.01
  • ATI: 8.40.4, 8.01 y 8.28.8

Cuando querramos cambiar de versión de driver, el autor recomienda utilizar la opción del envy “Desinstalar driver”. Pero si teneis un envy viejo (< 0.82) deberíais purgar el paquete. Lo mejor es que visiteis este FAQ que lo explica.

Fuente:

4 comentarios

  1. Yo dejé de usarlo en feisty porque cuando se actualizaba el kernel (via apt-get) se me buggeaba el driver. Cada vez que tnía una actualización de este tipo tenía que desinstalar el driver, reiniciar el nuevo kernell con VESA, y usar envy para reinstalar de nuevo el driver. Pero sólo lo usé en Feisty porque hicieron una chapuza en los repositorios con el driver normal y el legacy, y mi tarjeta no funcionaba con ninguno de los dos, ahora en gutsy no he tenido problemas por lo que no sabría decirte si han arreglado el problema de envy con las actualizaciones del kernell.

  2. Buenas Spayder26:

    La única buena solución es que el driver de nvidia venga por apt-get y cuando actualicen el kernel o el xorg también se actualice el driver en correspondencia al cambio.

    A mi también me paso poniendo el driver de forma manual, me vino una actualización del xorg que modificaba alguna librería crítica para el driver, entonces no me cargaban las X, tuve que recompilar el driver …

    El envy es como una instalación manual y no se entera de cuando cambian los paquetes a su alrededor, a si que lo único que podemos hacer es si proveemos que vamos a cambiar de driver, darle a uninstall y ya con el nuevo driver volver a instalar…

  3. Hola! espero me puedan echar una mano con mi problema.
    Luego de probar distintas distros, instalé la 6.06, las más actuales me presentaban problemas serios que las actualizaciones no solucionaban…
    En las anteriores podía instalar Envy NG sin mucho problema, y ahora no me deha instalar ninguna versión de este programa…ni para Hardy ni para este 6.06.
    Me dice en rojo algo como error: cannot install “build essential” y en consecuencia no puedo instalar mi gráfica, que es una Nvidia 6100. Actualicé Ubuntu y aún así pude.
    Saludos!

  4. ¿Te instala el paquete build-essential si escribes?
    sudo apt-get install build-essential

    ¿Que versión al final estas probando ?

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: